Noob questions, please?

All the topics related to QLC+ on the Raspberry Pi
technogeezer
Posts: 10
Joined: Tue Jul 11, 2017 12:54 pm
Real Name: Steve

Noob questions, please?

Post by technogeezer » Tue Jul 11, 2017 1:03 pm

Greetings,

I thought I had this bright idea to use my RPi for a light show controller with my band. I figured it would take months to work out the details. Then I found QLC+. It appears that most of the work has been done!

But I have a couple of questions, please.

* What does this mean (listed on RPi features page) - " Xorg is not present in the image."?

* Is there an alternative to paypal? I've had issues between them and my card company.

Any and all help would be greatly appreciated. Sorry if this has been asked already.

I really don't want to spend months figuring out how to build an image and where to get drivers, and all the other developer stuff. Heck, I do that for a living. Don't need it ALL day! QLC+ could be exactly what I need.

Thanks so much

User avatar
mcallegari
Posts: 1933
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Noob questions, please?

Post by mcallegari » Tue Jul 11, 2017 3:06 pm

* What does this mean (listed on RPi features page) - " Xorg is not present in the image."?
Xorg is the most used input/graphics server in the Linux world. On top of it there is usually a window manager.
The RPi image doesn't have any of that, because by default QLC+ is the only application running and it goes fullscreen.
The only downside effect is that it doesn't feel like a desktop PC environment, but the image is not actually meant to be used as if it was a desktop PC.
* Is there an alternative to paypal? I've had issues between them and my card company.
No sorry.

technogeezer
Posts: 10
Joined: Tue Jul 11, 2017 12:54 pm
Real Name: Steve

Re: Noob questions, please?

Post by technogeezer » Wed Jul 12, 2017 9:59 pm

I turn on the Pi and I see the screen scroll and the last line printed is

Debian GNU/Linux 8 Raspberry pi tty1

I can log in and that's it. If I type 'ls', nothing lists.

I can't access via any web browser. Says connection refused. Does the Pi *need* an address with zero as the third digit, i.e. 192.168.0.xxx?

When I power up with a regular debian card, the Pi works normally.

Any suggestions?

Thanks so much.

User avatar
mcallegari
Posts: 1933
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Noob questions, please?

Post by mcallegari » Thu Jul 13, 2017 7:37 am

Which Raspberry model do you have ?
Which image version are you running ?

The latest image needs some manual adjustment to run on RPi 1 / Zero / Zero W models. See here.

technogeezer
Posts: 10
Joined: Tue Jul 11, 2017 12:54 pm
Real Name: Steve

Re: Noob questions, please?

Post by technogeezer » Thu Jul 13, 2017 11:07 am

Sorry I didn't have more info.

My Pi is a model 2 B. I don't know which version it is but I think it's 1.2.

The image version is the one you told me to download in the email, 20170624. I received the email yesterday, 20170712.

Upon further research I found where QLC resides. I tried /usr/bin/qlcplus and the Pi returned 'invalid command'.

Qlcplus exists in the /usr/bin directory.

I can ping the Pi. Zero loss, all good. I can not access the web page, connection refused.

Thanks for your time.

User avatar
mcallegari
Posts: 1933
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Noob questions, please?

Post by mcallegari » Thu Jul 13, 2017 5:14 pm

Maybe the flashed image is corrupted or the SD card is about to die.
Have you tried to flash it again on the SD card or onto another SD card ?

technogeezer
Posts: 10
Joined: Tue Jul 11, 2017 12:54 pm
Real Name: Steve

Re: Noob questions, please?

Post by technogeezer » Thu Jul 13, 2017 5:24 pm

Brand new 8G SanDisk flash card. Not at the Pi right now. I'll try another card later.

Flashed the card twice from scratch.

Has anyone else been successful with that version I specified?

Linux is running for sure. It's just QLC+ that isn't working.

User avatar
mcallegari
Posts: 1933
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Noob questions, please?

Post by mcallegari » Thu Jul 13, 2017 5:37 pm

I tried /usr/bin/qlcplus and the Pi returned 'invalid command'.
I think that's indeed the issue.
Have you tried to update the Qt libraries with the command of the thread I linked above ?

technogeezer
Posts: 10
Joined: Tue Jul 11, 2017 12:54 pm
Real Name: Steve

Re: Noob questions, please?

Post by technogeezer » Thu Jul 13, 2017 5:44 pm

No, since that was not for my version of Pi.

However, when I get to the Pi, I can try that.

Has anyone verified the distro?

User avatar
mcallegari
Posts: 1933
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Noob questions, please?

Post by mcallegari » Thu Jul 13, 2017 6:24 pm

Just checked on my RPi 2.
Both original image and image + Qt 5.9.1 works OK.

Check also the img file against the provided MD5 sum.

Post Reply