Raspi Raspbian QLC+ Start at Boot question

All the topics related to QLC+ on the Raspberry Pi
Post Reply
tavonmarkov
Posts: 3
Joined: Sun Apr 12, 2015 6:33 pm
Real Name: Tavon Markov

Raspi Raspbian QLC+ Start at Boot question

Post by tavonmarkov » Mon May 22, 2017 6:20 pm

Can somebody, anybody point me in the right direction to help me get QLC+ to start right at boot? I am using Raspbian 8 (Jessie) on a RasPi 2 Mod B.

I have attempted the rc.local edit with adding a "qlcstart.desktop" script that commands a "start.sh" script... and still nothing happens on boot.

My "qlcstart.desktop" runs correctly when I double click it, as it is executable, but if I try to run it within a terminal window, it replies that the command isn't found...

I apologize in advance, I am not a fluent Linux user.

Thanks for the help!

janosvitok
Posts: 835
Joined: Mon Apr 13, 2015 7:05 am
Location: Bratislava, Slovakia
Real Name: Jano Svitok
Contact:

Re: Raspi Raspbian QLC+ Start at Boot question

Post by janosvitok » Mon May 22, 2017 6:37 pm

try to start /usr/bin/qlcplus from your rc script.

You can find the exact location by "which qlcplus".

tavonmarkov
Posts: 3
Joined: Sun Apr 12, 2015 6:33 pm
Real Name: Tavon Markov

Re: Raspi Raspbian QLC+ Start at Boot question

Post by tavonmarkov » Mon May 22, 2017 7:02 pm

My QLC+ program is located at
/home/pi/qlcplus

In my /home/pi directory, I have two files I created:
start.sh
qlcstart.desktop

start.sh contents:

sudo qlcplus &

qlcstart.desktop contents:

[Desktop Entry]
Name=qlcstart.desktop
Comment=Launch QLC+ Application at Startup
Exec=/home/pi/start.sh
Terminal=false
Type=Application

rc.local contents:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Print the IP address
_IP=$(hostname -I) || true
if [ "$_IP" ]; then
printf "My IP address is %s\n" "$_IP"
fi

#Start QLC+
/home/pi/start.sh &

exit 0

When I try to run rc.local in terminal window. I get

pi@qlc-pi:~ $ /etc/rc.local
My IP address is 192.168.1.12
pi@qlc-pi:~ $
Q Light Controller Plus version 4.11.0 GIT
This program is licensed under the terms of the Apache 2.0 license.
Copyright (c) Heikki Junnila (hjunnila@users.sf.net)
Copyright (c) Massimo Callegari (massimocallegari@yahoo.it)



--- i then have to hit enter before QLC Starts. If I change the lines after '#Start QLC+' to:
/home/pi/qlcstart.desktop

--- then run rc.local in terminal window. I get

pi@qlc-pi:~ $ /etc/rc.local
My IP address is 192.168.1.12
pi@qlc-pi:~ $ /home/pi/qlcstart.desktop: 1: /home/pi/qlcstart.desktop: [Desktop: not found
/home/pi/qlcstart.desktop: 3: /home/pi/qlcstart.desktop: QLC+: not found
^C

Post Reply