[FIXED] 4.10.3 RGB Matrix editor freeze

Archive of the non-categorized posts related to the QLC+ technical support.
Please do not create new threads here, instead, use the categories above !
Post Reply
Tasaei
Posts: 49
Joined: Sun Apr 19, 2015 8:55 am
Real Name: Jasper

[FIXED] 4.10.3 RGB Matrix editor freeze

Post by Tasaei » Mon Mar 07, 2016 9:32 am

Hi, i'll make it short .
Mac osx 10.11.3 / macbook 2,7 ghz i7 / 8 gb dd3

QLC+ 10.3
____________
1.New project
2. new generic rgb
3. Put it in a group
4. new rgb matrix
5. set the matrix to the new strobe function (issue is with every function)
6. If you set a very small hold-time ( under 10 ms ) QLC+ won't work anymore (frozen qlc+ screen)

Maybe my macbook is just to slow to work with these small periods of strobe, but than 75% of all computer will have that problem.
Last edited by Tasaei on Mon Mar 07, 2016 9:32 am, edited 2 times in total.

plugz
Posts: 637
Joined: Sun Apr 12, 2015 6:30 pm
Real Name: David

Re: Crash 10.3

Post by plugz » Mon Mar 07, 2016 10:03 am

Hello,

No issue here on linux.

Some questions:

- Is the issue present with another RGB script ? (like Stripes)

- What do you mean by "QLC+ won't work anymore" ? It becomes slow ? It hangs ? It crashes ?

- Do you have to run the matrix , or is it the preview running only ?

- Do you have any output configured on the universe containing the generic rgb ?

Tasaei
Posts: 49
Joined: Sun Apr 19, 2015 8:55 am
Real Name: Jasper

Re: Crash 10.3

Post by Tasaei » Mon Mar 07, 2016 10:16 am

1. Yes i think every function (i tried 4)
2. frozen QLC+ screen. Rest of programs an mac at itself works fine.
3. Just the preview.
4. doesnt matter, tried it with configured output and without

willmodelisme
Posts: 53
Joined: Wed Jan 20, 2016 7:50 pm
Location: PARIS France
Real Name:

Re: Crash 10.3

Post by willmodelisme » Mon Mar 07, 2016 11:06 am

Just to help, not a complain ;)

I tried it on windows 10 and experience also a frozen.
It seems it only happen when you set the time with the jog or scrolling with the mouse and you go below 10ms.
I wasn't able to reproduce the frozen when I set the time directly via keyboard.

QLC+ 4.10.3 RC3
Win 10
DMX USB Pro
Enttec DMX USB Pro
Windows 10

plugz
Posts: 637
Joined: Sun Apr 12, 2015 6:30 pm
Real Name: David

Re: Crash 10.3

Post by plugz » Mon Mar 07, 2016 12:46 pm

willmodelisme wrote:Just to help, not a complain ;)

I tried it on windows 10 and experience also a frozen.
It seems it only happen when you set the time with the jog or scrolling with the mouse and you go below 10ms.
I wasn't able to reproduce the frozen when I set the time directly via keyboard.

QLC+ 4.10.3 RC3
Win 10
DMX USB Pro
Thank you, I managed to reproduce the issue.

I'll look into it tonight.

plugz
Posts: 637
Joined: Sun Apr 12, 2015 6:30 pm
Real Name: David

Re: Crash 10.3

Post by plugz » Mon Mar 07, 2016 1:25 pm

Now fixed in GIT, thank you both


PS- It's not QLC+ 10.3, it's QLC+ 4.10.3 :)

willmodelisme
Posts: 53
Joined: Wed Jan 20, 2016 7:50 pm
Location: PARIS France
Real Name:

Re: Crash 10.3

Post by willmodelisme » Mon Mar 07, 2016 6:19 pm

We are really happy to help ;)
Enttec DMX USB Pro
Windows 10

Post Reply