[HEADS UP] Help needed to test incoming version 4.10.0

Archive of the non-categorized posts related to the QLC+ technical support.
Please do not create new threads here, instead, use the categories above !
mgweber
Posts: 45
Joined: Tue Apr 14, 2015 5:39 pm
Real Name: Matt Weber

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by mgweber » Wed Sep 30, 2015 2:17 pm

I have not found any issues with my workspace but I have not yet been able to test with the USB controller connected.

bestdani
Posts: 42
Joined: Tue May 26, 2015 11:13 am
Real Name: Daniel

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by bestdani » Wed Sep 30, 2015 3:04 pm

It does not depend on the pattern as far as I can see, but it depends on the current y position and affects the x movement component only, as far as I could figure out the effect is stronger the greater the distance from y=127.

Example workspace:
rgb-efx.qxw
(4.7 KiB) Downloaded 43 times

joky
Posts: 18
Joined: Tue Jul 07, 2015 5:18 pm
Real Name:

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by joky » Wed Sep 30, 2015 7:47 pm

Hi all,

I just built the latest 4.10.0 source from git on an RPi2 and tried to send some DMX data over my DMX4ALL USB Interface.

The interface itself seems to work (/dev/ttyUSB0 found, using a terminal I'm able to query some information and even under Win32 it works), but I fail to produce any DMX data using QLC+ (and even olad).


Plugin: DMX USB
Device "1: DMX4ALL PC USB INTERFACE"
Output: CHECK

Status says:
Device is operating correctly.
Driver in use: libFTDI
Protocol: DMX4ALL DMX-USB (Output)
Manufacturer: DMX4ALL

I also tried to start qlc+ as root, but the result was a blank application-window. I'm also not able to increase debugging information running qlcplus --debug 3 or --debug=3. I also tried to unload the ftdi-serial module, the ttyUSB0-device disappeared but the issue is still the same.


Is there an issue with the current code or I'm doing anything wrong?

regards

User avatar
mcallegari
Posts: 1898
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by mcallegari » Wed Sep 30, 2015 7:47 pm

joky wrote:I just built the latest 4.10.0 source from git on an RPi2 and tried to send some DMX data over my DMX4ALL USB Interface.
...
Is there an issue with the current code or I'm doing anything wrong?
No. I just built the GIT sources and tested on my RPi image with a DMX4ALL Stageprofi Mk2 device. All works fine.
You're probably messing up with user permissions so they cannot access /dev/ttyUSB.
By the way, since this is not the right place to discuss custom builds or the RPi, please open a separate thread in case (in the RPi forum)

User avatar
nedmech
Posts: 73
Joined: Sat Jun 20, 2015 12:39 am
Real Name: Nathan Durnan

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by nedmech » Thu Oct 01, 2015 3:17 am

I just tested 4.10.0_TEST-20150925 on my WinXP show machine. Successfully ran thru an existing show and made some edits without incident.

User avatar
sbenejam
Posts: 114
Joined: Sun Apr 12, 2015 6:28 pm
Real Name: Santiago Benejam Torres
Contact:

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by sbenejam » Thu Oct 01, 2015 6:24 pm

I tested on my system compiled yesterday with create-deb.sh no errors creating deb package. I tested old projects and all seems to work fine. My USB devices Enttec DMX USB Pro, Digitus DA-70157 USB RS-485 adapter and NanoKontrol2 are correctly detected and seems to work fine too (not tested with real fixtures connected).
My computer runs Ubuntu 15.04 with qlcplus compiled with Qt5.

Deece
Posts: 63
Joined: Thu Jul 23, 2015 1:42 pm
Real Name: Derek

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by Deece » Fri Oct 02, 2015 7:37 pm

One minor cosmetic fault, which I think is in 4.9.1 as well.
On the Channel Properties Configuration page, selecting LTP or HTP leaves the selection box on screen. You have to move the page to see the other options, but the selection box stays where it is, floating on screen.
Using Linux Mint 17.02 Rafaella (based on Ubuntu 14.04 ?)
(Must be fairly unique to me, as others have used ltp etc and not mentioned it.)

User avatar
mcallegari
Posts: 1898
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by mcallegari » Fri Oct 02, 2015 7:37 pm

Deece wrote:One minor cosmetic fault, which I think is in 4.9.1 as well.
On the Channel Properties Configuration page, selecting LTP or HTP leaves the selection box on screen. You have to move the page to see the other options, but the selection box stays where it is, floating on screen.
Using Linux Mint 17.02 Rafaella (based on Ubuntu 14.04 ?)
(Must be fairly unique to me, as others have used ltp etc and not mentioned it.)
I use Mint 17.2 and I don't experience that behaviour. Are you using QLC+ on Qt4 or Qt5 ?
Are you using weird Intel drivers or weird Mesa versions ?
I use a GIT version of Mesa and I experience a damn refresh issue on Chrome (similar to what you see) but no issue in QLC+

Deece
Posts: 63
Joined: Thu Jul 23, 2015 1:42 pm
Real Name: Derek

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by Deece » Fri Oct 02, 2015 7:37 pm

I use Mint 17.2 and I don't experience that behaviour. Are you using QLC+ on Qt4 or Qt5 ?
Are you using weird Intel drivers or weird Mesa versions ?
I use a GIT version of Mesa and I experience a damn refresh issue on Chrome (similar to what you see) but no issue in QLC+[/quote]


QT4. Not using anything strange that I know of. Nvidia 340.93
All other selectors work fine, just the ltp/htp .

I'll try to compile my own version..rather than a deb.

debbio
Posts: 23
Joined: Wed May 06, 2015 10:18 am
Real Name:

Re: [HEADS UP] Help needed to test incoming version 4.10.0

Post by debbio » Sat Oct 03, 2015 10:28 pm

On lubuntu 14.04 all works very well.. tomorrow I will try on my archlinux

Thank you!!

Post Reply