Concurrent sound effect and light chase

The issues found when using the Virtual Console
Post Reply
ChrisSa
Posts: 4
Joined: Mon Oct 30, 2017 3:16 pm
Real Name: Chris Saxton

Concurrent sound effect and light chase

Post by ChrisSa » Fri Nov 03, 2017 2:16 pm

Hi

I have been trying to create a combined thunder and lightning effect to be included in a cue list. Every method I have tried has failed as it appears that the sound effect somehow impacts on the lighting effect.

1. I created a simple flashing lighting chase to look like lightning - including appropriate duration timers.
2. I created a short audio function of a recording of thunder.

Next I put them together in a collection hoping they would run concurrently, and indeed when I test run the collection it seems to work fine. I get the thunder and lightning effect operating simultaneously. However, when I put the collection into a chase and run the chase, while the sound works, there lighting effect does not appear to do anything (according to the DMX monitor). I suspect that the timing of the thunder sound is somehow overriding the timing of the lighting effect within the chase, but I'm far from sure.

The collection works fine if activated by a button, but I really want to have it as part of the cue stack for the show. Am I doing something wrong?

I can supply a test .qxw file if anyone wants it.

User avatar
GGGss
Posts: 182
Joined: Mon Sep 12, 2016 7:15 pm
Location: Belgium
Real Name: Fredje Gallon

Re: Concurrent sound effect and light chase

Post by GGGss » Sun Nov 05, 2017 11:03 am

as a work-around I can come up with...

Install a dummy feedback channel and use it in your cue
the feedback fires the button you use with your collection.

the use of feedback's are discussed elsewhere
All electric machines work on smoke... when the smoke escape from machines... they don't work anymore

User avatar
sbenejam
Posts: 122
Joined: Sun Apr 12, 2015 6:28 pm
Real Name: Santiago Benejam Torres
Contact:

Re: Concurrent sound effect and light chase

Post by sbenejam » Sun Nov 05, 2017 4:52 pm

Can you post your project file?. Which OS?.

ChrisSa
Posts: 4
Joined: Mon Oct 30, 2017 3:16 pm
Real Name: Chris Saxton

Re: Concurrent sound effect and light chase

Post by ChrisSa » Wed Nov 08, 2017 1:27 pm

Thanks for your helpful responses. I have yet to look at the feedback suggestion, but will investigate this possibility.
I am running QLC+ 4.11.1 on an HP laptop running Windows10.
I have created a simple project to try to demonstrate the problem and attached the .qwx and sound effect I am using.
In the attached demonstration project I have just configured two dimmer channels. The intention was to create a "thunder and lightning" effect by triggering a flashing light chase simultaneously with the thunder sound effect from a single cue.

I created a chase called "flash" that simply flashes the dimmer channels for 2 seconds.
I created an audio function called "Short_Thunder" that plays back a 4S thunder sound effect.
I then put the flash chase and the sound effect into a collection called "Thunder and Lightning".
Finally I created a demo chase and cue list called "Run Show" that sets a few lights and runs the "Thunder and Lightning" collection.

Now, depending on the hold time associated with the "Thunder and Lightning" collection in the "Run Show" chase , I see and hear different results. Given the somewhat random results, it may be that they are dependent on the speed of my PC etc.

As setup in the attached project with a "Run Show" hold time set to 361ms. I hear the entire sound effect but the flash timing is not as expected, the dimmer channels stay ON for the length of the sound effect.

If I set the hold timer to zero, then the sound effect runs to completion, but the flash does not happen at all.
If I set the hold timer to 2 seconds, then the flash effect looks ok, but the sound effect is cut off after 2 seconds.
If I set the hold timer to 5 seconds both the thunder and flash effects occur as expected, but the cue list is stuck for the 5 seconds when I really want it to move on to the next lights control cue.

Apologies if this is too complicated for anyone to understand! I would appreciate any help anyone can provide so I can understand what's going on.
Attachments
Short_Ro-MM_Devel-8048_hifi.mp3
(62.57 KiB) Downloaded 3 times
demo sound issue.qxw
(3.77 KiB) Downloaded 4 times

User avatar
sbenejam
Posts: 122
Joined: Sun Apr 12, 2015 6:28 pm
Real Name: Santiago Benejam Torres
Contact:

Re: Concurrent sound effect and light chase

Post by sbenejam » Thu Nov 09, 2017 7:40 pm

ChrisSa wrote:
Wed Nov 08, 2017 1:27 pm
As setup in the attached project with a "Run Show" hold time set to 361ms. I hear the entire sound effect but the flash timing is not as expected, the dimmer channels stay ON for the length of the sound effect.

If I set the hold timer to zero, then the sound effect runs to completion, but the flash does not happen at all.
If I set the hold timer to 2 seconds, then the flash effect looks ok, but the sound effect is cut off after 2 seconds.
If I set the hold timer to 5 seconds both the thunder and flash effects occur as expected, but the cue list is stuck for the 5 seconds when I really want it to move on to the next lights control cue.

Apologies if this is too complicated for anyone to understand! I would appreciate any help anyone can provide so I can understand what's going on.
I tested all your options on my Xubuntu 17.04 and seems to work as expected.
Setting hold time to 361ms audio and lights plays for 361ms.
Setting hold time to 2s audio and lights plays for 2 s.
Setting hold time to 4s audio plays for 4s and lights for 2s.
Setting hold time to 5s audio plays entirely and lights for 2s plus 1s until reach 5s hold time.

I don't have a Windows machine at home to test this project. You can create a Show putting the audio in a track and lights in other track.

ChrisSa
Posts: 4
Joined: Mon Oct 30, 2017 3:16 pm
Real Name: Chris Saxton

Re: Concurrent sound effect and light chase

Post by ChrisSa » Fri Nov 10, 2017 3:10 pm

Thanks for testing. Still a bit of a mystery. No problem if I use a separate button for the effect.

kenact
Posts: 35
Joined: Thu Apr 23, 2015 6:43 am
Real Name: Ken Coughlin

Re: Concurrent sound effect and light chase

Post by kenact » Sun Nov 12, 2017 3:24 am

I used the Show Manager to create a Thunder & Lightning cue. I set up a track, adding the sound file, and added a scene, matching the scene that should be playing, with the addition of a couple of RGB/LEDs. adding enough steps to create the lightning effect.

Once the Show is created, I insert it into my main Chaser.

kenact
Posts: 35
Joined: Thu Apr 23, 2015 6:43 am
Real Name: Ken Coughlin

Re: Concurrent sound effect and light chase

Post by kenact » Sun Nov 12, 2017 6:31 pm

I have my thunder & lightning cue on another computer. I will post the qxw file within the next day or two. I've used it on several shows, and I've gotten numerous compliments on it.

Post Reply