MIDI Feedback No Longer Sent from Disabled Frame

The issues found when using the Virtual Console
siegmund
Posts: 561
Joined: Mon Nov 02, 2015 11:03 am
Location: Germany
Real Name: Lukas

Re: MIDI Feedback No Longer Sent from Disabled Frame

Post by siegmund » Tue Feb 14, 2017 4:13 pm

Thanks, I see now what happens - seems like a lucky catch :D
Anyway, thanks for the additional report, I wouldn't have noticed this otherwise.

User avatar
electronicsfreak
Posts: 1
Joined: Sat Sep 09, 2017 12:29 am
Real Name: Kodi_H

Re: MIDI Feedback No Longer Sent from Disabled Frame

Post by electronicsfreak » Wed Oct 18, 2017 7:21 am

Hi all!

New to QLC+ but am learning! Fun stuff.

I believe I'm having the same issue. When setting a button with midi feedback to enable/disable a frame, it looks like the enable frame feedback is sent, but disable frame feedback is not.

In operate mode:
Press button on controller, button illuminates on controller, frame is enabled in virtual console.
Press button on controller again, no change on the controller (button still illuminated), but the frame is disabled in virtual console.

I tried assigning different available buttons on the controller with feedback, but they all have the same result.

I am using an Akai APC40 as a controller and am running QLC+ version 4.11.0 on Windows 10

Any thoughts?

-EF

bluescreen25
Posts: 13
Joined: Fri Jul 21, 2017 4:52 pm
Real Name: Ralf Janssen

Re: MIDI Feedback No Longer Sent from Disabled Frame

Post by bluescreen25 » Sun Nov 26, 2017 7:46 pm

electronicsfreak wrote:
Wed Oct 18, 2017 7:21 am
When setting a button with midi feedback to enable/disable a frame, it looks like the enable frame feedback is sent, but disable frame feedback is not.
Same problem with V4.11.1 .

User avatar
mcallegari
Posts: 1935
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: MIDI Feedback No Longer Sent from Disabled Frame

Post by mcallegari » Mon Nov 27, 2017 8:46 pm

Enable feedback fixed on GIT
Test versions on the way

bluescreen25
Posts: 13
Joined: Fri Jul 21, 2017 4:52 pm
Real Name: Ralf Janssen

Re: MIDI Feedback No Longer Sent from Disabled Frame

Post by bluescreen25 » Wed Nov 29, 2017 3:33 pm

mcallegari wrote:
Mon Nov 27, 2017 8:46 pm
Enable feedback fixed on GIT
Test versions on the way
This works. APC Feedback in case of enable/disable frame ok....but:

I put a cue list into frame. Chaser invinite timed steps. In Chaser RGB Matrix steps inside with own times.
The cue list is triggered by midi-beat in "next step" like in tutorial "Audio triggered cue list".

If i disable frame , the cue list freezes(paused) in last step working endless, but it should stop not pause ! (because the light are already on)
Enabling the frame the trigger starts steps from last step paused. I wish to switch with APC Buttons between some cue lists.

regards, Ralf

Post Reply