Artnet - Arduino - Delay output

Generic issues not specifically related to a QLC+ area.
Post here only if you can't really find the reason of an issue
Post Reply
almarques
Posts: 22
Joined: Wed Mar 23, 2016 2:07 pm
Real Name: Alex Marques

Artnet - Arduino - Delay output

Post by almarques » Tue Oct 10, 2017 1:00 pm

Hello!
I assembled an Arduino-based artnet with 3 universes.

The first and second work well, but the third one has a very long delay, someone had a similar problem?

I did tests connecting in other software and also in other controllers and I have no problem in the third universe, only in QLC it has this delay.

The arduino system was built based on this:
http://www.deskontrol.net/blog/arduino- ... tnet-node/

Tks All!
---
Alex Marques
Elton Som e Eventos
www.eltonsom.com.br

User avatar
GGGss
Posts: 182
Joined: Mon Sep 12, 2016 7:15 pm
Location: Belgium
Real Name: Fredje Gallon

Re: Artnet - Arduino - Delay output

Post by GGGss » Tue Oct 10, 2017 3:02 pm

And what if you only try the third one?
* still timing troubles -> Arduino bad
* no more troubles -> check networking capabilities??

Narrowing the problem will show you the source of the problem
All electric machines work on smoke... when the smoke escape from machines... they don't work anymore

almarques
Posts: 22
Joined: Wed Mar 23, 2016 2:07 pm
Real Name: Alex Marques

Re: Artnet - Arduino - Delay output

Post by almarques » Tue Oct 10, 2017 5:06 pm

Hello,
how much testo with other programs or in other consoles via artnet I do not have this problem.

Always use the same connection scheme (same router and same cables)

It happens in universe 3 ... in 1 and 2 I have no delay.

I also used to test this software, which looks for artnet devices on the network
http://www.artisticlicence.com/index.ph ... uct_id=351

In it everything works correctly, I do all the tests in the 3 universes without any delay.

I have already tested on other PC and MAC computers and the problem is always the same ...

Tks!
---
Alex Marques
Elton Som e Eventos
www.eltonsom.com.br

User avatar
GGGss
Posts: 182
Joined: Mon Sep 12, 2016 7:15 pm
Location: Belgium
Real Name: Fredje Gallon

Re: Artnet - Arduino - Delay output

Post by GGGss » Wed Oct 11, 2017 10:05 am

Are you broadcasting or unicasting?
* these setting can be different between software products and QLC+ can be set to unicast or broadcast... (even sending the full scope [universe] or only the relevant info)

Saying it works with other products won't help solving your troubles with QLC+ - just saying ;-)
All electric machines work on smoke... when the smoke escape from machines... they don't work anymore

almarques
Posts: 22
Joined: Wed Mar 23, 2016 2:07 pm
Real Name: Alex Marques

Re: Artnet - Arduino - Delay output

Post by almarques » Wed Oct 11, 2017 4:06 pm

Hello, it's not a comparative issue, running the other programs is just a parameter for me to try with the help of the forum to solve the problem, I like the QLC and I continue to use it successfully with 2 universes.

I have already made this change, without success as well.
---
Alex Marques
Elton Som e Eventos
www.eltonsom.com.br

Post Reply