Crashing When creating sequences in shows or using EFXs

Generic issues not specifically related to a QLC+ area.
Post here only if you can't really find the reason of an issue
Post Reply
BDDV07
Posts: 5
Joined: Fri Feb 10, 2017 2:27 pm
Real Name: David

Crashing When creating sequences in shows or using EFXs

Post by BDDV07 » Tue Jun 20, 2017 5:24 am

Hey there!

Just wanted to send some crash reports. I have very continuous crashes when trying to add new sequences when building a show.

Basically what I'm doing is after selecting and setting a ver sequences, I'll go to add something between a few sequences and CRASH, re-open, try again, crash.
I'll also experience crashes when I pretty much try to do anything to a EFX inside the show builder window. Move it, look at it, adjust it. Anything, crash crash crash.

Another thing I found was when trying to delete video files in the function window, it will crash after clicking delete. Trying to delete anything inside the show builder window often causes a crash.

I'm using a MacBook Pro (2011'ish) with El Cap
I was using QLC+ 4.10.5b but I also tested this on 4.11 and the crashing happened in both places just as frequently.

Hope this is helpful info to try to de-bug. I'm building shows to run in a live setting that is automated to backing tracks along with visuals so hopefully I won't have any trouble after building these shows. At any rate, there you go. Thanks!

siegmund
Posts: 561
Joined: Mon Nov 02, 2015 11:03 am
Location: Germany
Real Name: Lukas

Re: Crashing When creating sequences in shows or using EFXs

Post by siegmund » Tue Jun 20, 2017 2:47 pm

Hey,

to reproduce the crash quick & easy please share a workspace file and an exact step by step instruction to reproduce the issue(s).

Thanks,
siegmund

BDDV07
Posts: 5
Joined: Fri Feb 10, 2017 2:27 pm
Real Name: David

Re: Crashing When creating sequences in shows or using EFXs

Post by BDDV07 » Wed Jun 21, 2017 6:08 pm

(PRE POST NOTE- I did a screen grab of all my issues you can watch here)


I'm not sure I can get that issue to repeat, but I probably get the sequencing crash to happen for you. Attached in my show file.

So the kit I'm using is ADJ TriPar Profile and then some generic Chinese version of the 12w ADJ Inno Pocket Spot LED.

So if you open my show file (I put a screen grab) a place that I get a crash every time is when trying to add a squience to the mover position track you see on the show program called "James Bond Ninja." When you try to put it between the beginning and the case on a few seconds later. Here is the best way to explain.

- Open QLC
- Open workspace File
- Go to Shows on Function bar (Bottom)
- Select "James Bond Ninja" from show list
- Got to mover position track (3rd track line down)
- Put curser anywhere between start and 6 seconds (before all over chase sequence)
- Then go to toolbar and click "new sequence ." You should get a crash.

The work around I have is to add the function in a new track (which I did) but I shouldn't have too.

THe other thing is, I'm loosing memory between saves of about 2-3 scenes. They are always moving head positions and even after I save everything and correct the DMX address for the pan/tilt, they always clear themselves out when I re-open my project making everything F'd up in my saved shows. I set my "HOME" position as 170 on pan, and these always reset to 0 as I didn't even do anything. I haven't searched the forum yet on this issue but figured I'd share that as well.


--
I've edited the youtube link to show the video. inline @janosvitok
Attachments
QLC sequence crash in show builder.jpg
Live Show - Ground Package .qxw
(175.95 KiB) Downloaded 19 times

BDDV07
Posts: 5
Joined: Fri Feb 10, 2017 2:27 pm
Real Name: David

Re: Crashing When creating sequences in shows or using EFXs

Post by BDDV07 » Wed Jun 21, 2017 7:47 pm

Here is another example of the addresses not saving or memorizing even between just toggling back and froth between sequences. one second I have the values inputed and saved, the next it's back to zero.

It's very much causing my work flow to be drastically reduced. If my moves won't do what I need them too, I'll have to reprogram my whole show for each track to work with just washes, which would be sad :-(

Hope this feedback helps. You can use the same project file as in the pervious post.

https://www.youtube.com/watch?v=xnsLlfr ... e=youtu.be

User avatar
mcallegari
Posts: 1934
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Crashing When creating sequences in shows or using EFXs

Post by mcallegari » Fri Jun 23, 2017 7:25 pm

I have reproduced the crash, and fixed it. Thanks for the accurate report.

However, I have no idea how you ended up with a workspace like that, but track 3 was bound to a Sequence when normally it should be bound to a Scene.
As for the "values go to 0" thing, the explanation is simple: you're using those Scenes as containers for Sequences. They are not "normal" Scenes anymore.
I have repeated an awful amount of times not to use Scenes bound to Sequences elsewhere. The behavior you see is actually correct.

I really really hope this will stop with QLC+ 4.11.0, because people kept using Sequences+Scenes in the wrong way and what you experienced is all a consequence of that.

In fact, if you migrate your project with the Sequence converter, those Scenes (e.g. Down 2.0) will disappear.

Post Reply