Random crashes on Windows and macOS - hopefully solved - please help testing

Generic issues not specifically related to a QLC+ area.
Post here only if you can't really find the reason of an issue
User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Random crashes on Windows and macOS - hopefully solved - please help testing

Post by mcallegari » Sun Jan 22, 2017 3:18 pm

Hi, I'm opening a new thread about this, but this has been reported quite a few times:
viewtopic.php?f=32&t=10628
viewtopic.php?f=32&t=9865
viewtopic.php?f=32&t=10276
viewtopic.php?f=24&t=9863

Apparently it affects only Windows and macOS builds. At first I also thought it was related to DMX USB PRO devices, but it seems it wasn't.

Yesterday I spent the whole day trying to figure it out. Being random it's been quite long to tackle.
I've set up a very simple project (attached - just push the 2 buttons in the VC) and configured an Enttec MK2 to output 2 universes.
I've done 3 runs:
- Windows 7 - QLC+ 4.10.5b - 30 minutes: crashed
- Windows 7 - QLC+ 4.10.5b - 2 hours: didn't crash. Interrupted
- Ubuntu 14.04 - QLC+ GIT build - 5 hours: didn't crash. Interrupted

So after a bit of struggle to find how to properly debug the code on Windows (Windows 10 in this case), today I found something.
I've run a GIT code build and it "luckily" spotted a crash after less than 30 minutes.
I've applied a fix and hopefully the cause of all evil should be gone now.

So, I kindly ask everybody that have experienced random crashes, to please test the latest TEST versions with either their projects or the attached one, at least for a couple of hours.
Then please report if it works or not for you.

Windows: Automated builds (updated: 2017-03-10)
OSX 10.7+: QLC+_4.10.6-TEST-20170326.dmg

[EDIT 10:55pm] the macOS build ran for 6 hours with no crashes
Attachments
2uniEnttecMk2.qxw
(25.11 KiB) Downloaded 31 times

User avatar
hplighting
Posts: 14
Joined: Sun Dec 18, 2016 2:58 pm
Location: England
Real Name: Henry

Re: Random crashes on Windows and macOS - hopefully solved - please help testing

Post by hplighting » Mon Jan 23, 2017 8:23 pm

Hi Massimo,
Thanks for investigating this problem - much appreciated :)
I've been running the test build and workspace for a few hours now with no crashes. I'll try and run it a bit longer though just encase...
Thanks Again !

Henry P

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Random crashes on Windows and macOS - hopefully solved - please help testing

Post by mcallegari » Mon Jan 23, 2017 10:17 pm

Very good, thanks for the feedback

mgweber
Posts: 45
Joined: Tue Apr 14, 2015 5:39 pm
Real Name: Matt Weber

Re: Random crashes on Windows and macOS - hopefully solved - please help testing

Post by mgweber » Tue Jan 24, 2017 6:42 pm

Hi, thank you for looking into this. I will download and test on a separate system than what I use at the theater. That has been the only place that I saw the issue but I will test anyway. My show system I installed Linux as dual boot last night. I was using a VM with Linux for a few days with good results until I was able to do an actual install.

One difference I noticed is that with the Windows build the UI has a significant slowdown when entering scenes when connected the the USB-DMX interface. I did not notice that with the Unix install. I will stick with the dual boot configuration on that system just for the responsiveness of the UI.

User avatar
tornel
Posts: 20
Joined: Sun Apr 12, 2015 2:54 pm
Location: La Paz, Bolivia
Real Name: Luis Garcia-Tornel

Re: Random crashes on Windows and macOS - hopefully solved - please help testing

Post by tornel » Tue Jan 24, 2017 7:47 pm

Reporting here:

Ubuntu Mate 16.04: testing for about 3 hours with the test project. No crash or interrupt.
Windows 7: testing for about 4 hours with the test project. No crash or interrupt.
:lol:

shortylight
Posts: 31
Joined: Sat Nov 21, 2015 7:06 pm
Location: Münster / Germany
Real Name: Martin Kurze

Re: Random crashes on Windows and macOS - hopefully solved - please help testing

Post by shortylight » Tue Jan 24, 2017 7:55 pm

Hi,

I did two tests on Windows 8.1 for more than 3 hrs without a crash.

Martin

austriancoder
Posts: 2
Joined: Tue Jan 24, 2017 10:19 pm
Real Name: Christian Gmeiner

Re: Random crashes on Windows and macOS - hopefully solved - please help testing

Post by austriancoder » Tue Jan 24, 2017 10:39 pm

Hi.

Windows 7 with enttec dmx usb pro mk2 (one universe) with Midi input: crashed 5 times within 3 hours. I try to build it on Windows and run it in under qtcreators debugger to see if I find something. With the current state it is not the best choice for a live performance :(

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Random crashes on Windows and macOS - hopefully solved - please help testing

Post by mcallegari » Wed Jan 25, 2017 7:51 am

austriancoder wrote:Windows 7 with enttec dmx usb pro mk2 (one universe) with Midi input: crashed 5 times within 3 hours. I try to build it on Windows and run it in under qtcreators debugger to see if I find something. With the current state it is not the best choice for a live performance :(
Care to share some more information about your setup ?
- did you use my test project or one of yours ? (in case please share the faulty workspace)
- does it make any difference with/without MIDI input ?
- did you make sure you are using a clean installation of the test build linked above ?

User avatar
hplighting
Posts: 14
Joined: Sun Dec 18, 2016 2:58 pm
Location: England
Real Name: Henry

Re: Random crashes on Windows and macOS - hopefully solved - please help testing

Post by hplighting » Wed Jan 25, 2017 1:04 pm

Thinking about it mine also used to crash while using a MIDI input.
I'll use my MIDI controller with the new version to see if I can get it to crash...
mcallegari wrote:
austriancoder wrote:Windows 7 with enttec dmx usb pro mk2 (one universe) with Midi input: crashed 5 times within 3 hours. I try to build it on Windows and run it in under qtcreators debugger to see if I find something. With the current state it is not the best choice for a live performance :(
Care to share some more information about your setup ?
- did you use my test project or one of yours ? (in case please share the faulty workspace)
- does it make any difference with/without MIDI input ?
- did you make sure you are using a clean installation of the test build linked above ?

mgweber
Posts: 45
Joined: Tue Apr 14, 2015 5:39 pm
Real Name: Matt Weber

Re: Random crashes on Windows and macOS - hopefully solved - please help testing

Post by mgweber » Wed Jan 25, 2017 2:03 pm

Hi,

I have a fairly large workspace with an accumulation of several shows. I have two windows 10 systems at home. First system has been running is running 4.10.5b with *no* dmx interface for literally days with no issue. The second system I installed the test version posted in this thread. I am using a single universe Entec Pro with the same workspace. I ran it for two runs of about 3 hours each. I interrupted it to create a sample for another thread.

I need to test with the Pro Mk2 from the theater but I won't have access to use that at home for testing until after Sunday (show weekend).

I may be wrong but it sure feels like an issue caused in some way by the Pro Mk2. When I look at what works and what doesn't that is the only unique item for the system that crashes.

BTW, I am using the Pro Mk2 as two universes out with no midi input.

Thanks,
Matt

Post Reply