qlcplus 4.10.3a on debian jessie based system

Ask a question about the usage of QLC+ with the Linux operating system
Post Reply
sebo505
Posts: 3
Joined: Wed May 11, 2016 7:30 pm
Real Name:

qlcplus 4.10.3a on debian jessie based system

Post by sebo505 » Thu May 12, 2016 10:09 am

Hi,

I am using qlcplus on a debian jessie based system. I am using a DMX USB NanoDMX Interface (DMX4ALL). This interface gets detected properly. qlcplus says that the interface is ready to use ant that the libFTDI driver is used.
So I added my fixture (ignition LED PAR64 floor 20x3 W PWM RGB). But the fixture does not respond at all.
Any suggestions?

sschaeffner
Posts: 2
Joined: Mon Aug 24, 2015 9:47 pm
Location: Munich, Germany
Real Name: Simon Schäffner
Contact:

Re: qlcplus 4.10.3a on debian jessie based system

Post by sschaeffner » Thu May 12, 2016 10:46 am

Hi,

1. check your cables,
2. check your dmx address set on the fixture,
3. try with simple desk
4. try with another fixture

If none of these steps solve your problem, there's most likely a problem with your dmx interface. If you have any windows based pc around, maybe try with that.

Simon

sebo505
Posts: 3
Joined: Wed May 11, 2016 7:30 pm
Real Name:

Re: qlcplus 4.10.3a on debian jessie based system

Post by sebo505 » Thu May 12, 2016 12:25 pm

Cables are fine
dmx address is fine
fixture is fine
does not work with simple desk either
dmx interface is brandnew

haven't tried a windows machine yet, but must be something else.
Any ideas ?

sebo505
Posts: 3
Joined: Wed May 11, 2016 7:30 pm
Real Name:

Re: qlcplus 4.10.3a on debian jessie based system

Post by sebo505 » Thu May 12, 2016 5:19 pm

i also tried to add the user to the group dialout. this did not change anything.
though I figured out that everything is working fine if I start qlcplus as root.

So, what do I have to change for that it is also working as normal user?

User avatar
mcallegari
Posts: 1933
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: qlcplus 4.10.3a on debian jessie based system

Post by mcallegari » Fri May 13, 2016 7:22 am

Looks like the udev rules are not applied.
Or probably your user must be added to the 'dialout' group.
Check groups until

Code: Select all

echo "foo" > /dev/ttyUSB0
works

Post Reply