uDMX issue--not sending in QLC+ until I UNpatch device

The issues found when using the Input/Output Manager panel
Post Reply
smc
Posts: 1
Joined: Sun Aug 20, 2017 12:35 pm
Real Name:

uDMX issue--not sending in QLC+ until I UNpatch device

Post by smc » Sun Aug 20, 2017 1:28 pm

I have a few humble fixtures that I like to use on occasion and I have a cheap uDMX controller (Lixada--I know, get what pay for and all that) that I am trying to get working with QLC+.

When I patch my udmx device to my universe and adjust something, nothing happens. Until I unpatch; then the latest channel values get sent through until I either flip the output back to udmx or unplug the device. That's pretty weird and now I'm stumped.
This does not happen with Freestyler or the basic uDMX console program (but I really don't want to use those).
This does not appear to be version specific (I tried a few of the older releases and they did it too)
This does not appear to be OS specific (I prefer linux but I tested this in Windows too)

Originally I was guessing it was just crappy hardware or drivers but with all of the above that seems unlikely. I figure I've reasonably narrowed it down to QLC+. I also ran a search on the forums, and while it looks like there will be some fun timing issues in my future, I didn't actually find anything similar to this.

I'd be happy to provide lsusb dumps or anything else that could be useful. I don't have a DMX tester or much in the way of spare hardware though; I am better versed in computers than DMX.

Post Reply