Fedora: I/O plugin loader fails with the fedora package

The issues found when using the Input/Output Manager panel
Post Reply
Rik
Posts: 12
Joined: Mon Jul 20, 2015 7:51 pm
Real Name:

Fedora: I/O plugin loader fails with the fedora package

Post by Rik » Fri Aug 04, 2017 2:00 pm

Hi there,

I have a problem finding any connected DMX interfaces, for instance the DMXControl Nodle U1. It worked a year ago on my laptop with fedora 24. Now with fedora 25/26 the same DMX devices do not show up.

I installed the debug version from the repo and get the following output:

Code: Select all

[rik@localhost ~]$ qlcplus -d

Q Light Controller Plus version 4.11.1 GIT
This program is licensed under the terms of the Apache 2.0 license.
Copyright (c) Heikki Junnila (hjunnila@users.sf.net)
Copyright (c) Massimo Callegari (massimocallegari@yahoo.it)

bool QLCFixtureDefCache::addFixtureDef(QLCFixtureDef*) Cache already contains "lightmaXX Platinum CLS-1"
"/usr/share/qlcplus/fixtures/lightmaXX-Platinum-CLS-1.qxf" not in FixturesMap.xml
bool QLCFixtureDefCache::addFixtureDef(QLCFixtureDef*) Cache already contains "lightmaXX Platinum CLS-1"
void IOPluginCache::load(const QDir&) "libartnet.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libartnet.so'"
void IOPluginCache::load(const QDir&) "libdmx4linux.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libdmx4linux.so'"
void IOPluginCache::load(const QDir&) "libdmxusb.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libdmxusb.so'"
void IOPluginCache::load(const QDir&) "libe131.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libe131.so'"
void IOPluginCache::load(const QDir&) "libenttecwing.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libenttecwing.so'"
void IOPluginCache::load(const QDir&) "libhidplugin.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libhidplugin.so'"
void IOPluginCache::load(const QDir&) "libloopback.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libloopback.so'"
void IOPluginCache::load(const QDir&) "libmidiplugin.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libmidiplugin.so'"
void IOPluginCache::load(const QDir&) "libosc.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libosc.so'"
void IOPluginCache::load(const QDir&) "libpeperoni.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libpeperoni.so'"
void IOPluginCache::load(const QDir&) "libspi.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libspi.so'"
void IOPluginCache::load(const QDir&) "libudmx.so" doesn't contain an I/O plugin: "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/qlcplus/libudmx.so'"
Can someone help?


edit:
dmesg output:

Code: Select all

[100678.325525] usb 2-1: new full-speed USB device number 9 using xhci_hcd
[100678.495807] usb 2-1: New USB device found, idVendor=16d0, idProduct=0830
[100678.495812] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[100678.495815] usb 2-1: Product: Nodle U1
[100678.495817] usb 2-1: Manufacturer: DMXControl Projects e.V.
[100678.495820] usb 2-1: SerialNumber: 2000000000000009
[100678.501155] hid-generic 0003:16D0:0830.0004: hiddev0,hidraw0: USB HID v1.10 Device [DMXControl Projects e.V. Nodle U1] on usb-0000:00:14.0-1/input0
Last edited by Rik on Fri Aug 04, 2017 3:47 pm, edited 1 time in total.

janosvitok
Posts: 851
Joined: Mon Apr 13, 2015 7:05 am
Location: Bratislava, Slovakia
Real Name: Jano Svitok
Contact:

Re: Linux no dmx devices found

Post by janosvitok » Fri Aug 04, 2017 2:04 pm

Can you check the dates of the plugins whether are they fresh enough or from previous install?

Rik
Posts: 12
Joined: Mon Jul 20, 2015 7:51 pm
Real Name:

Re: Linux no dmx devices found

Post by Rik » Fri Aug 04, 2017 2:23 pm

They are from July 19th 1017:

Code: Select all

[rik@localhost ~]$ ll /usr/lib64/qt5/plugins/qlcplus/
total 2096
drwxr-xr-x. 2 root root   4096 Aug  4 16:22 audio
-rwxr-xr-x. 1 root root 255408 Jul 19 20:30 libartnet.so
-rwxr-xr-x. 1 root root  70480 Jul 19 20:30 libdmx4linux.so
-rwxr-xr-x. 1 root root 270600 Jul 19 20:30 libdmxusb.so
-rwxr-xr-x. 1 root root 238488 Jul 19 20:30 libe131.so
-rwxr-xr-x. 1 root root 154408 Jul 19 20:30 libenttecwing.so
-rwxr-xr-x. 1 root root 158744 Jul 19 20:30 libhidplugin.so
-rwxr-xr-x. 1 root root  91528 Jul 19 20:30 libloopback.so
-rwxr-xr-x. 1 root root 275824 Jul 19 20:30 libmidiplugin.so
-rwxr-xr-x. 1 root root 263808 Jul 19 20:30 libosc.so
-rwxr-xr-x. 1 root root 129104 Jul 19 20:30 libpeperoni.so
-rwxr-xr-x. 1 root root 112528 Jul 19 20:30 libspi.so
-rwxr-xr-x. 1 root root  91616 Jul 19 20:30 libudmx.so

janosvitok
Posts: 851
Joined: Mon Apr 13, 2015 7:05 am
Location: Bratislava, Slovakia
Real Name: Jano Svitok
Contact:

Re: Linux no dmx devices found

Post by janosvitok » Fri Aug 04, 2017 2:32 pm

how did you install your build?

if you did sudo make install:
do "sudo make uninstall" that should remove qlcplus from /usr/bin and all the plugins. If they are still there, remove them manually. I suppose you have uninstalled any qlcplus package.

if you created package and installed that:
uninstall the package, and make sure no plugins are left. if they are, delete them manually.


Check the date of plugins in your build/source directory, and if they are old (June IS old I suppose) than "make clean" and build the whole project again.


Then install again, using whatever method you choose.

Rik
Posts: 12
Joined: Mon Jul 20, 2015 7:51 pm
Real Name:

Re: Linux no dmx devices found

Post by Rik » Fri Aug 04, 2017 2:36 pm

I installed it from scratch (no qlcplus installed previously on the system) using the provided fedora repo (https://software.opensuse.org/download. ... us-qt5-git).

I removed it using the fedora package manager and all plugins got also removed. A new install does not change anything on the error though.

Rik
Posts: 12
Joined: Mon Jul 20, 2015 7:51 pm
Real Name:

Re: Linux no dmx devices found

Post by Rik » Fri Aug 04, 2017 3:16 pm

On Ubuntu it works fine inside a virtual machine. On fedora the Input/Output tab Mapping is completely empty.

Rik
Posts: 12
Joined: Mon Jul 20, 2015 7:51 pm
Real Name:

Re: Linux no dmx devices found

Post by Rik » Fri Aug 04, 2017 3:46 pm

Compiling it from source solved it for me.

So I guess there is a problem with the package in the fedora repo.

LaKing
Posts: 9
Joined: Mon Oct 17, 2016 10:43 pm
Real Name: István Király

Re: Fedora: I/O plugin loader fails with the fedora package

Post by LaKing » Fri Dec 22, 2017 5:18 pm

I compiled the package, as for me the Input/Output Mapping is empty as well.

However, after compiling from source only the USB plugin appeared. ...

Investigating further .. but it would be nice to fix the Fedora package. They are broken since ages.

Post Reply