Stop midi input on windows 10

The issues found when using the Input/Output Manager panel
Post Reply
User avatar
luca
Posts: 14
Joined: Tue Feb 23, 2016 11:43 am
Location: Rome
Real Name: lucas

Stop midi input on windows 10

Post by luca » Tue Jun 20, 2017 2:10 pm

Hi ,
It's about 3 weeks since connecting a new usb (pen drive, usb mouse) qlc + (4.10.5b and QLC+_4.11.0.xxx) loses communication with the midi (apc mini) device. I've verified on my laptop and my home pc with windows 10. The same versions of qlc+ on windows 7 works properly.

The test is:
1 - open qlc+
2 - go to Inputs/Outputs
3 - set midi in on universe ( 1 2 3 or 4)
4 - connect, or disconnect, one usb device (usb pen drive or mouse .. keyboard ...)

Now I lost midi comunication .

For restore comunication:
5 - With a double click on a midi line "MIDI" on "Mapping" pannel, open configure midi plugin
6 - Press "Refresh" to find midi device

Some times windows display "qlc has stoped to working" .

I use qlc midi control on my laptop in the last 2 year for many hours without problems.

Does anyone have the same problem?

Thanks,

Luca

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Stop midi input on windows 10

Post by mcallegari » Tue Jun 20, 2017 6:36 pm

First: please spare us from "urgent" matters. That word doesn't exist in this project.

Secondly, I think you already have the answer to your question: Windows 7 works, Windows 10 doesn't.
It means something has changed on W10 regarding USB that makes a mess within QLC+.

I'll have a look at this when I have some time. Most likely this is related to how QLC+ handles hotplugging. Maybe an option to disable it will avoid unexpected behaviors.

User avatar
luca
Posts: 14
Joined: Tue Feb 23, 2016 11:43 am
Location: Rome
Real Name: lucas

Re: Stop midi input on windows 10

Post by luca » Tue Jun 20, 2017 8:52 pm

Sorry Massimo,
I apologize to everyone for having written "urgent" in the post. If you think a "urgent" request was a critic for developer was not my intention.
I understand that it is linked to the operating system but asking a people in a forum one test is off-topic? I was hoping someone could help me solve it. The point 8 on the Issues reporting guidelines "Always consider that if something doesn't work in your environment, it doesn't mean it won't work for everybody."

Good Evening.

Luca

User avatar
GGGss
Posts: 230
Joined: Mon Sep 12, 2016 7:15 pm
Location: Belgium
Real Name: Fredje Gallon

Re: Stop midi input on windows 10

Post by GGGss » Wed Jun 21, 2017 9:15 am

A possible solution:

1. Scroll to the right and type 'Power Options' in the search field and click on it.
2. Click 'Change plan setting' on your chosen plan.
3. Click 'Change advanced power setting' on your chosen plan.
4. Find 'USB settings' and open.
5. Find 'USB selective suspend setting' and change it to disabled. - See more at: http://www.tomshardware.co.uk/answers/i ... 4LEqW.dpuf
Cap_ 2017-06-21 11.12-199.png
Sorry for the image not being English - my O.S. is in Dutch
All electric machines work on smoke... when the smoke escapes... they don't work anymore

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Stop midi input on windows 10

Post by mcallegari » Sat Jun 24, 2017 11:20 am

I cannot reproduce the issue.
I have tested QLC+ 4.11.0 on Windows 10 with a APC Mini set for input and feedback.

I can correctly plug unplug devices (tried with mouse and USB pendrive)
No crash at all

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Stop midi input on windows 10

Post by mcallegari » Fri Jul 07, 2017 7:27 pm

Please test the latest test version here

I have added a button to enable/disable USB hotplugging. It's now disabled by default

MrBenj
Posts: 13
Joined: Sat Jun 24, 2017 8:27 am
Real Name: Ethan Benjamin

Re: Stop midi input on windows 10

Post by MrBenj » Fri Jul 14, 2017 10:15 am

Hi Massimo,

Where is the button to enable or disable USB hotswapping? I can't seem to find it.

Warm regards,
Ethan Benjamin

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Stop midi input on windows 10

Post by mcallegari » Fri Jul 14, 2017 11:44 am

Underneath the plugin configuration button.
As I said, hotplugging is now disabled by default, so you don't need to press the button at all.

Post Reply