Crash when adding something to the scene

The issues found when using the Show Manager panel
User avatar
portapipe
Posts: 22
Joined: Thu Apr 28, 2016 7:51 am
Real Name:

Crash when adding something to the scene

Post by portapipe » Tue May 03, 2016 1:46 pm

I really don't know what happened but with OS X el capitan QLC crash so much... and I'm in front of the customer...
This is the crash log:

http://pastebin.com/P0T06rSt

Hope this will figure out what is the issue.

plugz
Posts: 637
Joined: Sun Apr 12, 2015 6:30 pm
Real Name: David

Re: Crash when adding something to the scene

Post by plugz » Tue May 03, 2016 1:56 pm

Hello,

Workspace file ?

Steps to reproduce ?

Thank you

User avatar
portapipe
Posts: 22
Joined: Thu Apr 28, 2016 7:51 am
Real Name:

Re: Crash when adding something to the scene

Post by portapipe » Tue May 03, 2016 2:07 pm

How to reproduce it:
Show -> + Button to add anything to the show

Thanks
Attachments
Twilight RIPENSATO (riassegnato) MA VUOTO.qxw
(367.19 KiB) Downloaded 41 times

plugz
Posts: 637
Joined: Sun Apr 12, 2015 6:30 pm
Real Name: David

Re: Crash when adding something to the scene

Post by plugz » Tue May 03, 2016 2:32 pm

Thank you, I managed to reproduce the crash on QLC+4.10.3a. I''ll try to have a look when I have some time.

User avatar
portapipe
Posts: 22
Joined: Thu Apr 28, 2016 7:51 am
Real Name:

Re: Crash when adding something to the scene

Post by portapipe » Tue May 03, 2016 8:06 pm

Thanks, let me hope that this will be fixed :oops:

User avatar
portapipe
Posts: 22
Joined: Thu Apr 28, 2016 7:51 am
Real Name:

Re: Crash when adding something to the scene

Post by portapipe » Wed May 04, 2016 6:08 am

I did some tests and I found that If you open the file with a 4.8.5 qlc+ version you'll see some sequences to be in the chaser's folder, BUT the icon is of the sequences (plus I don't have any chaser). With 4.9 an above you'll didn't see that and I've worked with 4.10.3a all the time in a regular way (nothing odd, I have dimmers and bulbs).

Image

plugz
Posts: 637
Joined: Sun Apr 12, 2015 6:30 pm
Real Name: David

Re: Crash when adding something to the scene

Post by plugz » Wed May 04, 2016 9:20 am

Now fixed in GIT, thank you

User avatar
portapipe
Posts: 22
Joined: Thu Apr 28, 2016 7:51 am
Real Name:

Re: Crash when adding something to the scene

Post by portapipe » Wed May 04, 2016 9:28 am

Oh great! Can I ask what was the problem? Now I can download it or I have to wait?
Thanks!

plugz
Posts: 637
Joined: Sun Apr 12, 2015 6:30 pm
Real Name: David

Re: Crash when adding something to the scene

Post by plugz » Wed May 04, 2016 10:06 am

The problem is that some sequences in your workspace have been created with an ID smaller than the scene they are attached to, and QLC+ does not handle this well.

This also caused the display issues you saw in 4.8.5 (in the Function Manager).


portapipe wrote:Now I can download it or I have to wait?
You'll have to wait for the next TEST version to be out, I don't know when that will be.

User avatar
portapipe
Posts: 22
Joined: Thu Apr 28, 2016 7:51 am
Real Name:

Re: Crash when adding something to the scene

Post by portapipe » Wed May 04, 2016 10:11 am

Oh I saw that numbers and it was weird but I don't know how QLC works behind the hood so... thanks, I'll wait.

Post Reply