Editing Functions in Show deletes values

The issues found when using the Show Manager panel
Post Reply
CoS2000
Posts: 15
Joined: Tue Aug 29, 2017 1:00 pm
Real Name:

Editing Functions in Show deletes values

Post by CoS2000 » Mon Sep 18, 2017 9:58 am

Hi@ all,

when i edit a function (for example a Sequence) direct in show manager it causes that values get lost or changed! I had 3 scenes, editing one of them in show manager, sometimes it changes the values in other functions that used in the show! Its not every time, but its irritating when programming a whole show! Sometimes changing of values of a function in a show causes changes in other function in other shows i made!

A workaround is editing functions in functions manager only, but this costs time!

Its not easy to reproduce this bug. Often it works when you copy a copy: Make a Function, set it in the show and make a copy of this function in the show. Then make a copy of the copy and change values. In most Cases changing values of the 2nd copy (copy of copy of function-name) changes values in all other copys too!

The result sometimes is fascinating: I have 4 Color-LED Bars. I make a function "bars red" that makes the bars red and dims them to 50%. Than i make a copy of "bars red" with 75% intensity. Then i make a copy of that copy and change the intensity to 100% - Result: all other copys are blue with 20% intensity ;-) - In this case it doesnt matter if i make the changes of the copys copy in function manager!

I programming by myself and know its hard to fix a error that you cant reproduce easily, but i hope you can find problem!

Sorry for my not so perfect english!

Regards,
CoS

Post Reply