Problem: Show slowing with complex chasers

The issues found when using the Show Manager panel
Post Reply
ethanm3
Posts: 36
Joined: Mon Dec 28, 2015 2:50 am
Real Name: Ethan Moses

Problem: Show slowing with complex chasers

Post by ethanm3 » Tue Dec 20, 2016 7:22 pm

Hello,

First I want to say I have really enjoyed using QLC+ and really appreciate all the time going into this program.

I am having an issue with my Christmas light setup. I am using the show manager to sync a pixel show to a song. This is working very well, except when I have some of the more complex sequences running at once. I have 1000 pixels in the setup, and the sequences where I am strobing colors of all 1000 of them creates a lag, so the song and the show go out of sync. As I watch it, the yellow time cursor slows down when this scene plays, then that makes everything after it out of sync. I have tried using a wav file and mp3 file, and even not having the music in it at all. What seems to be the issue, though, is a chaser that I have made to time a collection of strobing pixels in different colors. This seems to be too complex for QLC+ and slows down the playback and makes it go out of sync.

Do you have any suggestions to make playback smoother? Or is this program just not meant for such a high amount of pixels?

Here is the file: https://www.dropbox.com/s/0c6k9a5fxpd5h ... t.qxw?dl=0

Here is a video of the playback slowing down: https://www.dropbox.com/s/1f5xjgq5sv5l8 ... t.mov?dl=0

Please let me know if I should add more details to help you.

Thank you so much!

Ethan Moses
Savory Lighting Design

janosvitok
Posts: 835
Joined: Mon Apr 13, 2015 7:05 am
Location: Bratislava, Slovakia
Real Name: Jano Svitok
Contact:

Re: Problem: Show slowing with complex chasers

Post by janosvitok » Tue Dec 20, 2016 8:32 pm

Operating system + version? QLC+ version? HW configuration (CPU/RAM)?

janosvitok
Posts: 835
Joined: Mon Apr 13, 2015 7:05 am
Location: Bratislava, Slovakia
Real Name: Jano Svitok
Contact:

Re: Problem: Show slowing with complex chasers

Post by janosvitok » Tue Dec 20, 2016 9:37 pm

I've tried to run it on my computer and it run quite smoothly, if I ignore excessive swapping when I switched applications.
Computer: intel Q6600 quadcore, 4 GB RAM, HDD, Kubuntu 16.04 64 bit, QLC+ 4.10.6git

QLC+ allocated 6 GB RAM (vsz) and actually used 2+ GB (rsz). That is a bit too much provided the file has ~70 MB...

ethanm3
Posts: 36
Joined: Mon Dec 28, 2015 2:50 am
Real Name: Ethan Moses

Re: Problem: Show slowing with complex chasers

Post by ethanm3 » Wed Dec 21, 2016 11:34 pm

QLC version 4.10.1

OSX 10.11.6

2.8 GHz Intel Core i7

16 GB 1600 MHz DDR3

I think what is slowing it down is that I am using a collection inside the chaser for some of those scenes ("all BIG color strobe ending..."). This collection is several sequences on top of each other, and each is complex, so maybe I should avoid using collections in the Show mode... Is there a way to paste one sequence onto another sequence in the same way that a collection would work? What I mean is, I want the strobe sequence that is blue on top of the red on top of the white, etc. Is there a way to do that without collections?

Thank you!

Ethan

User avatar
mcallegari
Posts: 1932
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Problem: Show slowing with complex chasers

Post by mcallegari » Sat Dec 24, 2016 10:54 am

That is indeed a massive project !

I downloaded it and saw the slowing down issue as well, with the latest sources and on Linux.
Now, what I can say after a quick look at your project is this: for such a massive amount of LEDs, try to avoid Scenes (therefore Sequences) as much as you can. RGB Matrices can help you a lot and they are more efficient when dealing with large amount of LEDs. For example a strobe can be simply performed by the "Strobe" preset

Other than that, I think you have reached the limit of the poor QLC+ engine and there is no solution to that :(

The good news is that on my PC QLC+ 4 loads your project in 26seconds, while QLC+ 5 takes just 8 seconds !

In any case, it would be nice to see a video of the whole show when you perform it. If you don't mind, please submit it to viewtopic.php?f=30&t=7460

ethanm3
Posts: 36
Joined: Mon Dec 28, 2015 2:50 am
Real Name: Ethan Moses

Re: Problem: Show slowing with complex chasers

Post by ethanm3 » Sat Dec 24, 2016 6:45 pm

Thanks for all the help! I am so very glad to be using QLC+, and I'm excited to see 5 come out!

I had found previously that RGB Matrices are also complex with a big show like this, but I didn't do very much testing on that so I imagine you are correct and there was something else going on at that time. I have made some changes and I think it works now. I got a great video with my GoPro, so once that is uploaded I will definitely share my project!

I have one question/suggestion regarding your advice: I have been trying to find the best solution to having a large amount of pixels strobing randomly. What I mean is, making something like Random Single preset but with multiple pixels at once, not just one. One workaround has been making a collection of several Random Strobe matrices, but this is cumbersome. Another workaround is to make a new fixture group that has all my pixels kind of randomly mapped in a fixture group, and then using a preset like Stripes or Balls which will make an effect like a random strobe. This is also not a perfect solution, though, so I would love to see a Random Strobe preset, similar to Random Single but where you can select how many pixels go up at a time and perhaps what colors, too!

Thank you!

Ethan

Post Reply