Channel Modifier Editor not applying dimmer curve

The issues found when using the Fixture Manager panel
Post Reply
Posts: 31
Joined: Thu May 07, 2015 10:34 am
Real Name: Edgar Aichinger

Channel Modifier Editor not applying dimmer curve

Post by edogawa » Thu Jan 26, 2017 9:51 am


I searched the forum and bug tracker and couldn't find my issue anywhere.

The two 24-Channel DMX-LED-Converter boxes I had ordered from AliExpress have now arrived and I'm experimenting with some LED lights (12 V white and RGB strips and OSRAM 12V dimmable LED PAR16 Spots with GU5,3 sockets).

So far everything is working fine, except that the PAR16 doesn't play so well with the LED dimmer, flashes up when going from 0 to 1 % and changes intensity in steps rather than smoothly, when fading it slowly. I have to find out if there are better dimmers for this kind of lamp, if i can find better lamps, or have to change them for something else, because I cannot use them in theater like this (it's puppet theater, before you start to wonder).

The striplights behave better and dim pretty smoothly, only the step from 0 to 1% is too big to start a smooth fadeing curve. Thus I tried to experiment with the Channel Modifiers in Fixture manager/Channel properties configuration.
I can use that dialog, make my own custom template and save it to the list, if I quit that modifier dialog the new template name is shown in the Modifier column of that channel, but if I click OK here nothing happens and next time I open the same dialog my settings are all gone.

To make sure that it isn't on my side I just recompiled 4.10.3 (that's a version I seem to remember it had worked) against Qt4 and indeed it remembers and applies the modifier just as expected.

I've run git log on the ChannelModifierEditor.cpp file and see the last commit to this is from 2015, so that tells us nothing.
Also I can't seem to find the slot function for clicking OK in that dialog, or which data structures get updated in that case. Maybe I haven't looked hard enough, anyways you see that my Qt/C++ experience is lacking.

Please tell me how to proceed, I can try several things: compile 4.10.3 against Qt5 to see if that makes a difference, compile 4.10.4 (compiling it right now against Qt4 as I write this) and try the 4.10.5 binary package to narrow down where the bug starts to show. Both the OBS packages of 4.10.6-git-qt5 and my local qt5 build from current git fail, i also could try to build this current git against Qt4 etc. I'd have to read up on git bisect to learn about that, but I'm willing to do that too if you want me to.

Thanks, Edgar

Posts: 850
Joined: Mon Apr 13, 2015 7:05 am
Location: Bratislava, Slovakia
Real Name: Jano Svitok

Re: Channel Modifier Editor not applying dimmer curve

Post by janosvitok » Thu Jan 26, 2017 11:58 am


I quickly tried 4.10.5b on win10. I could not find a problem. Can you provide step by step process how to reproduce?


Posts: 31
Joined: Thu May 07, 2015 10:34 am
Real Name: Edgar Aichinger

Re: Channel Modifier Editor not applying dimmer curve

Post by edogawa » Thu Jan 26, 2017 1:34 pm

Hello Jano,

I have just found out that it affects only Qt5 builds here.

Just after writing the post above I compiled 4.10.4 from sources against Qt4 and it worked as it should.

make uninstall, make distclean and qmake-qt5, then make resulted in a qt5 build and there it doesn't work anymore

As a cross check, my next step will be to reinstall qlcplus-git-qt4 distro package (OpenSUSE Tumbleweed from OBS).

EDIT: I just did that and it confirms what I thought, the Qt4 build works and the modifier curve gets applied.

Steps to reproduce:

start qlcplus
add fixture (I tried both Generic Dimmer and Generic RGB)
go to channel fade properties
expand the device entry and click the modifier button for whatever intensity channel
channel modifier editor dialog opens, change curve to another template, e.g. strong logarithmic
click OK
click OK in channel fade properties (which has a different window title from that at the icon tooltip, btw)
re-open channel fade properties dialog

In Qt4 builds, the template is still shown, in Qt5 builds the modifier button shows "..." again, no template got applied

On a similar track in Qt5 I cannot choose a recent workspace from the list that appears after a long mouse button press on the load file icon; this also works in Qt4 (but may require a separate topic in general issues)

Cheers, Edgar

Post Reply