Inconsistent Behavior From Identical Fixtures

The issues found when using the Fixture Manager panel
Post Reply
DavidH
Posts: 10
Joined: Thu Oct 27, 2016 5:45 pm
Real Name: David H Silber

Inconsistent Behavior From Identical Fixtures

Post by DavidH » Wed Nov 02, 2016 5:20 pm

I have two Martin Roboscan Pro 918 fixtures set up in QLC+. I created a Chaser to strike the lamps of them (and a Martin MX-10) at 5 second intervals. One of the 918s failed to strike (I'm doing this offline and watching the Fixture Monitor, so no actual hardware was involved). After a lot of trying to figure what I had configured wrong, including deleting and recreating the misbehaving fixture, I changed its DMX address to be immediately before rather than immediately after the working 918 and it just works as expected.

Both 918s are using the DMX4 mode.

Original addresses were 201 - 216 for #1 and 217 - 232 for #2

Working addresses are 185 - 200 for #2 and 201 - 217 for #1

I would love to have the time to dig into the software and be able to offer a fix to go with the problem report, but I've got a show in tech. Perhaps next month will be calmer.

Thanks for all work that has gone into this software.

David

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Inconsistent Behavior From Identical Fixtures

Post by mcallegari » Wed Nov 02, 2016 8:30 pm

What do you mean by "strike" ?

Please be more specific about what channels you're controlling and what you are expecting.
A sample project to reproduce what you see would help.

janosvitok
Posts: 848
Joined: Mon Apr 13, 2015 7:05 am
Location: Bratislava, Slovakia
Real Name: Jano Svitok
Contact:

Re: Inconsistent Behavior From Identical Fixtures

Post by janosvitok » Wed Nov 02, 2016 8:48 pm

Massimo, I suppose "strike" means "switch off the lamp/bulb". See https://github.com/mcallegari/qlcplus/b ... 18.qxf#L34

David, please post your workspace. How do you connect the fixtures to the computer?
I suspect that the problem may be caused by not transmitting trailing zeros. Try raising any channel after the last mapped channel in the simple desk. Depending on your output plugin, there may be a setting to force output of full packets.

DavidH
Posts: 10
Joined: Thu Oct 27, 2016 5:45 pm
Real Name: David H Silber

Re: Inconsistent Behavior From Identical Fixtures

Post by DavidH » Wed Nov 02, 2016 8:48 pm

janosvitok wrote:Massimo, I suppose "strike" means "switch off the lamp/bulb". See https://github.com/mcallegari/qlcplus/b ... 18.qxf#L34
Actually, "strike" in this context means to light the lamp, as in striking a match. This follows the terminology that Martin uses in their manuals. I'm sorry for any confusion.
janosvitok wrote:David, please post your workspace.
See attached. Unfortunately, I don't have a copy of the workspace from when I was having the problem. Also, I have since moved those Martin 918s from universe 1 to universe 3. If needed, I can attempt to recreate the issue.
janosvitok wrote:How do you connect the fixtures to the computer?
I suspect that the problem may be caused by not transmitting trailing zeros. Try raising any channel after the last mapped channel in the simple desk. Depending on your output plugin, there may be a setting to force output of full packets.
I'm using a DMXKing eDMX board, which is an Art-Net node that supports four universes of DMX, each of which can be an output or an input.


Thanks,
David
Attachments
Nice Work Show.qxw
(51.33 KiB) Downloaded 36 times

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: Inconsistent Behavior From Identical Fixtures

Post by mcallegari » Wed Nov 02, 2016 9:51 pm

@Jano: he said he sees the issue with the DMX monitor, so it doesn't seem related to an output transmission

janosvitok
Posts: 848
Joined: Mon Apr 13, 2015 7:05 am
Location: Bratislava, Slovakia
Real Name: Jano Svitok
Contact:

Re: Inconsistent Behavior From Identical Fixtures

Post by janosvitok » Thu Nov 03, 2016 9:17 pm

David, one of your Z--- strike scenes has value 170 and the other 230. It looks like 170 is wrong.

Jano

Post Reply