fedora 27 package?

Request a feature that you would like to see in QLC+.
Explain in details why you would need it and which is your usage case.
Post Reply
giacomo
Posts: 88
Joined: Tue May 26, 2015 6:17 pm
Real Name: Giacomo

fedora 27 package?

Post by giacomo » Sun Nov 19, 2017 6:53 pm

quick question, is it possible to update the OBS download to fedora 27?
thanks

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: fedora 27 package?

Post by mcallegari » Sun Nov 19, 2017 9:09 pm

It's not supported yet. F27 has been released 5 days ago...

giacomo
Posts: 88
Joined: Tue May 26, 2015 6:17 pm
Real Name: Giacomo

Re: fedora 27 package?

Post by giacomo » Tue Nov 21, 2017 4:41 pm

also F26 as been released since almost 5 months...
OBS it's a bit behind.
cheers

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: fedora 27 package?

Post by mcallegari » Tue Nov 21, 2017 5:20 pm

OBS distros are enabled manually (by me). It's not automatic.
Nobody requested Fedora 26 so I haven't enabled it.

LaKing
Posts: 9
Joined: Mon Oct 17, 2016 10:43 pm
Real Name: István Király

Re: fedora 27 package?

Post by LaKing » Fri Dec 22, 2017 4:03 pm

Please provide us with recent Fedora packages. There are many users using it .) ...

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: fedora 27 package?

Post by mcallegari » Sat Dec 23, 2017 1:57 pm

QLC+ on OBS and F26/F27 doesn't build cause of an open issue on OLA.
https://github.com/OpenLightingProject/ola/issues/1192

edogawa
Posts: 31
Joined: Thu May 07, 2015 10:34 am
Real Name: Edgar Aichinger

Re: fedora 27 package?

Post by edogawa » Mon Dec 25, 2017 11:08 am

Hello,

I am packaging several software that I use myself, in this OBS project:

https://build.opensuse.org/project/show/home:edogawa

Regarding qlc+, I usually build it for myself locally, and to make the ola part work, I decided to fall back to an older protobuf package from some other OBS location instead of the "official" distro provided one, and build ola against this. Both of these I branched to my own project and this made qlcplus compile.

https://build.opensuse.org/package/show ... wa/qlcplus

Yesterday I've added a Fedora 27 target repository. Just be aware that I used and renamed the qt5 git package variant from massimo's project (see the Appimage part below to understand why I renamed) as that's what I use normally.

Also I started to experiment with building AppImages (universal/not distro-specific packages similar to dmg bundles on MacOS) for qlc+ as mentioned in another post, but currently this doesn't produce a useful package, for two reasons:

1. Currently it isn't possible to launch the fixture editor from that bundle (currently the binary to be lunched has to carry the package name, i.e. qlcplus in my case)
2. Resource paths aren't relocatable, instead the binary holds hard coded absolute paths read at compile time from a header file. I haven't had time yet to investigate further, but there likely is a way to deal with this properly, or as a workaround for now. Bear with me if anyone is interested in this. I tend to spend some time on stuff, then take a rest if it gets all too complicated, but usually come back some undefined time later again ;)

Cheers and happy holidays,

Edgar

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: fedora 27 package?

Post by mcallegari » Tue Jan 02, 2018 3:33 pm

qt5-git packages for Fedora 26 and 27 are now available on OBS.
I had to exclude the OLA plugin.

Now I'm trying to build 4.11.1 on F26/27 too

LaKing
Posts: 9
Joined: Mon Oct 17, 2016 10:43 pm
Real Name: István Király

Re: fedora 27 package?

Post by LaKing » Fri Feb 09, 2018 8:07 am

Thank you very much! .)

User avatar
mcallegari
Posts: 1997
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: fedora 27 package?

Post by mcallegari » Sun Feb 18, 2018 4:58 pm

@edogawa how did you manage to have Qt 5.9.3 in your OBS + AppImage repository ?
I tried to add Leap:42.2:Update/standard and Leap:42.2:standard like you did, but it still installs Qt 5.6, which is not good for QLC+ 5

[EDIT] nevermind. Qt 5.9.3 is the version installed in my system. The AppImage you created doesn't actually bundle the Qt libraries.
So, right now OBS is no go to package QLC+ 5. I am trying to use linuxdeployqt manually but it doesn't work either.

Post Reply