QLC+ TEST versions

User avatar
lorenzoandreani
Posts: 56
Joined: Tue Sep 01, 2015 9:19 am
Location: Marina di Carrara
Real Name: Lorenzo Andreani

Re: QLC+ TEST versions

Post by lorenzoandreani » Sun Apr 23, 2017 3:28 am

QLC+_4.11.0.1 (22/04/2017) on Windows 10 crash when open a .qxw workspace.

I think the problem is due to the new sequence management because if you convert the file to the online converter, the problem does not occur.
Attachments
Crash Sequence.qxw
(124.07 KiB) Downloaded 18 times

User avatar
mcallegari
Posts: 1782
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: QLC+ TEST versions

Post by mcallegari » Sun Apr 23, 2017 7:46 am

lorenzoandreani wrote:
Sun Apr 23, 2017 3:28 am
QLC+_4.11.0.1 (22/04/2017) on Windows 10 crash when open a .qxw workspace.

I think the problem is due to the new sequence management because if you convert the file to the online converter, the problem does not occur.
Indeed, after a recent rework on Sequences, backward compatibility is interrupted.
However, QLC+ should not crash and should show an error message saying that projects using sequences must be converted to the new format with the migration tools.

Anyway, I've fixed the crash on GIT, thanks for reporting.

User avatar
nedmech
Posts: 73
Joined: Sat Jun 20, 2015 12:39 am
Real Name: Nathan Durnan

Re: QLC+ TEST versions

Post by nedmech » Mon Jul 10, 2017 12:27 am

Finally got around to trying out 4.11.0 on my oldest production machine only to encounter the following error:

"Procedure entry point CancelIoEx could not be located in the dynamic link library KERNEL32.dll"

This particular computer is still running Windows XP (for various reasons). I'm assuming that compatibility with Windows XP has now been broken by the change to QT 5.9? The QT support page only lists Windows support back to Win7 (http://doc.qt.io/qt-5/supported-platforms.html). Can you confirm if that's really the case, or is this some other glitch I've run into?

janosvitok
Posts: 773
Joined: Mon Apr 13, 2015 7:05 am
Location: Bratislava, Slovakia
Real Name: Jano Svitok
Contact:

Re: QLC+ TEST versions

Post by janosvitok » Mon Jul 10, 2017 7:25 am


User avatar
mcallegari
Posts: 1782
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: QLC+ TEST versions

Post by mcallegari » Mon Jul 10, 2017 12:05 pm

At this point, I think bundling Qt 5.9 was a mistake.
There's been reports of issues also with older macOS versions.
Most likely 4.11.1 will bundle Qt 5.6.2 again but guys, I cannot support dinosaurs forever.
The world is moving on:
- Microsoft even stopped XP support
- Apple is constantly polling you to update to the very latest macOS version...until your Mac (or iPhone/iPad) will need to be thrown in the trash can

I don't understand why QLC+ can't adapt to these tendencies.

I really hope QLC+ 5 will draw a line on this. In any case Qt 5.9 will be the minimum version required for technical reasons.

User avatar
nedmech
Posts: 73
Joined: Sat Jun 20, 2015 12:39 am
Real Name: Nathan Durnan

Re: QLC+ TEST versions

Post by nedmech » Tue Jul 11, 2017 3:14 am

Thanks for confirming this, Massimo & Jano. I've got no problem with QLC+ moving forward and dropping support for XP. I plan to upgrade that machine to Windows 10 soon. I'm mostly waiting on my IT guy to actually purchase what we need to upgrade it.

User avatar
mcallegari
Posts: 1782
Joined: Sun Apr 12, 2015 9:09 am
Location: Italy
Real Name: Massimo Callegari
Contact:

Re: QLC+ TEST versions

Post by mcallegari » Mon Jul 17, 2017 6:38 pm

I have reverted to Qt 5.6.2. Now test builds should work again on XP and Vista too.
I'm wondering though if in keeping Qt back we're missing something valuable, like for example multimedia improvements.
Apparently not (the damn issue of 0x0 videos has not been fixed (in years) yet) but still, the doubt remains.

Post Reply